前人未踏の領域へ アプリ開発編

Android, iOSアプリ開発に関する調査メモ置き場。ほとんどAndroid。はてなダイアリーから移行したため古い記事にはアプリ以外も含まれます。

Ubuntu-14.04にnokogiriをインストールする

可能な限り gemで管理したいので必要そうなライブラリを入れてインストール。

$ sudo apt-get ruby ruby-dev cpp gcc libxml2 libxml2-dev libxlst1.1 libxslt1-dev
$ sudo gem install nokogiri --use-system-libraries

が、上記でもエラーになり、すぐに解決しなそうだったのでapt-getで入れてしまうことに。

$ sudo apt-get install ruby-nokogiri
$ nokogiri -v
# Nokogiri (1.6.1)
    ---
    warnings: []
    nokogiri: 1.6.1
    ruby:
      version: 1.9.3
      platform: x86_64-linux
      description: ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]
      engine: ruby
    libxml:
      binding: extension
      source: system
      compiled: 2.9.1
      loaded: 2.9.1

1.6.1がインストールされるが、まあ良しとしよう。