前人未踏の領域へ アプリ開発編

Android, iOSアプリ開発に関する調査メモ置き場。ほとんどAndroid。古い記事にはアプリ以外も含まれます。

Android Studio 4.1 Beta 1に上げる際にビルドできなくなる

課題

Android Studio 4.1 Beta 1がリリースされたため早速ダウンロードして起動してみたところ、 以下のエラーが出てビルドできなくなった。

Gradle sync failed: No such property: scope for class: com.android.build.gradle.internal.variant.ApplicationVariantData

対応

直接の原因が何かは分からないが、Fabricを外すとビルドが通った。 Fabricはクラッシュログを取るのに必要なものだったが、すでにサポート終了で Firebase Crashlyticsへの移行が求められている状況だったため、このタイミングで移行することに。

Firebase Crashlyticsへの移行自体は変更量は多いものの、使用メソッドごとに代替メソッドに 一括置換すればほぼOKだったのでそこまで時間はかからなかった。

ググってもあまり情報が出たこなかったので、もしかしたらFabricが原因かもよ、と記しておく。